| Summary: A front end for testing other programs |
| Name: dejagnu |
| Version: 1.5 |
| Release: 4%{?dist} |
| Epoch: 1 |
| License: GPLv3+ |
| Source: ftp://ftp.gnu.org/gnu/dejagnu/dejagnu-%{version}.tar.gz |
| Source2: dejagnu.texi |
| Group: Development/Tools |
| URL: http://www.gnu.org/software/dejagnu/ |
| Requires: expect |
| BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
| BuildArch: noarch |
| BuildRequires: expect screen texinfo |
| Patch1: dejagnu-1.5-smp-1.patch |
| Patch2: dejagnu-1.5-runtest.patch |
| Patch3: dejagnu-1.5-usrmove.patch |
| Patch4: dejagnu-1.5-gfortran.patch |
| |
| %description |
| DejaGnu is an Expect/Tcl based framework for testing other programs. |
| DejaGnu has several purposes: to make it easy to write tests for any |
| program; to allow you to write tests which will be portable to any |
| host or target where a program must be tested; and to standardize the |
| output format of all tests (making it easier to integrate the testing |
| into software development). |
| |
| %prep |
| %setup -q |
| %patch1 -p1 |
| %patch2 -p1 |
| %patch3 -p1 |
| %patch4 -p1 |
| |
| %build |
| %configure -v |
| makeinfo %{SOURCE2} -o doc/%{name}.info |
| |
| %check |
| echo ============TESTING=============== |
| |
| |
| |
| |
| TMP=`mktemp` |
| screen -D -m sh -c '(make check RUNTESTFLAGS="RUNTEST=`pwd`/runtest"; echo $?) >> '$TMP |
| RESULT=`tail -n 1 $TMP` |
| cat $TMP |
| rm -f $TMP |
| echo ============END TESTING=========== |
| exit $RESULT |
| |
| %install |
| rm -rf $RPM_BUILD_ROOT |
| make DESTDIR=$RPM_BUILD_ROOT install |
| rm -f $RPM_BUILD_ROOT%{_infodir}/dir |
| chmod a-x $RPM_BUILD_ROOT/%{_datadir}/dejagnu/runtest.exp |
| make DESTDIR=$RPM_BUILD_ROOT install-man |
| install -D -m 644 doc/dejagnu.info $RPM_BUILD_ROOT/%{_infodir}/%{name}.info |
| |
| %post |
| /sbin/install-info %{_infodir}/%{name}.info.gz --dir-file=%{_infodir}/dir &> /dev/null |
| : |
| |
| %preun |
| if [ $1 = 0 ]; then |
| /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir &> /dev/null |
| fi |
| : |
| |
| %clean |
| rm -rf $RPM_BUILD_ROOT |
| |
| %files |
| %defattr(-,root,root) |
| %doc COPYING NEWS README AUTHORS ChangeLog doc/dejagnu.texi |
| %{_bindir}/runtest |
| %{_datadir}/dejagnu |
| %{_includedir}/dejagnu.h |
| %{_mandir}/*/* |
| %{_infodir}/dejagnu* |
| |
| %changelog |
| * Mon May 14 2012 Honza Horak <hhorak@redhat.com> 1:1.5-4 |
| - gfortran support added |
| Resolves: |
| |
| * Thu Mar 15 2012 Honza Horak <hhorak@redhat.com> 1:1.5-3 |
| - fixed search runtest.exp after usrmove |
| Resolves: |
| |
| * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.5-2 |
| - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild |
| |
| * Tue Mar 22 2011 Honza Horak <hhorak@redhat.com> 1:1.5-1 |
| - Update to 1.5, license changed to GPLv3+ |
| |
| * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.4.4-18 |
| - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild |
| |
| * Fri Jan 22 2010 Jiri Moskovcak <jmoskovc@redhat.com> - 1.4.4-17 |
| - added utils speedup patch from jakub@redhat.com |
| - Resolves: |
| |
| * Fri Oct 16 2009 Jiri Moskovcak <jmoskovc@redhat.com> - 1.4.4-16 |
| - fixed installation with --excludedocs rhbz |
| |
| * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.4.4-15 |
| - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild |
| |
| * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.4.4-14 |
| - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild |
| |
| * Wed Aug 27 2008 Jiri Moskovcak <jmoskovc@redhat.com> - 1:1.4.4-13 |
| - rewriten patch to work with fuzz=0 |
| |
| * Wed Aug 27 2008 Jiri Moskovcak <jmoskovc@redhat.com> - 1:1.4.4-12 |
| - fixed runtest (patch from jan.kratochvil@redhat.com) |
| - Resolves: |
| |
| * Mon Nov 12 2007 Petr Machata <pmachata@redhat.com> - 1:1.4.4-11 |
| - Install info file. |
| - Resolves: |
| |
| * Thu Oct 4 2007 Petr Machata <pmachata@redhat.com> - 1:1.4.4-10 |
| - A few more cleanups after discussion with reviewer. |
| - Resolves: |
| |
| * Wed Oct 3 2007 Petr Machata <pmachata@redhat.com> - 1:1.4.4-9 |
| - Clean up spec per merge review comments. |
| - Fix testsuite. |
| - Resolves: |
| |
| * Thu Aug 16 2007 Petr Machata <pmachata@redhat.com> - 1:1.4.4-8 |
| - Fix licesing tag. |
| |
| * Wed Mar 7 2007 Petr Machata <pmachata@redhat.com> - 1:1.4.4-7 |
| - Remove mention of dejagnu.info from manpage, per comments in |
| doc/Makefile. |
| - Resolves: |
| |
| * Wed Feb 7 2007 Petr Machata <pmachata@redhat.com> - 1:1.4.4-6 |
| - Tidy up the specfile per rpmlint comments |
| |
| * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:1.4.4-5.1 |
| - rebuild |
| |
| * Wed Feb 2 2006 Petr Machata <pmachata@redhat.com> 1:1.4.4-5 |
| - Applying H.J. Lu's race condition patch. ( |
| |
| * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> |
| - rebuilt |
| |
| * Sat Mar 5 2005 Jakub Jelinek <jakub@redhat.com> 1:1.4.4-4 |
| - rebuilt with GCC 4 |
| |
| * Mon Nov 8 2004 Jakub Jelinek <jakub@redhat.com> 1:1.4.4-3 |
| - add URL ( |
| |
| * Mon Sep 27 2004 Warren Togami <wtogami@redhat.com> 1:1.4.4-2 |
| - remove INSTALL & redundant copies of overview |
| |
| * Tue Aug 3 2004 Jakub Jelinek <jakub@redhat.com> 1:1.4.4-1 |
| - update to 1.4.4 |
| - run make check during rpm build |
| |
| * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> |
| - rebuilt |
| |
| * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> |
| - rebuilt |
| |
| * Wed Jan 22 2003 Tim Powers <timp@redhat.com> |
| - rebuilt |
| |
| * Mon Dec 30 2002 Karsten Hopp <karsten@redhat.de> 1:1.4.2-9 |
| - more missing BuildRequires |
| |
| * Tue Dec 17 2002 Karsten Hopp <karsten@redhat.de> 1:1.4.2-8 |
| - Add jadetex Buildrequires |
| |
| * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 1:1.4.2-7 |
| - include dejagnu.h |
| - move %%{_libexecdir}/config.guess into %%{_datadir}/dejagnu |
| - include overview docs (bug |
| |
| * Fri Jun 21 2002 Tim Powers <timp@redhat.com> |
| - automated rebuild |
| |
| * Thu May 23 2002 Tim Powers <timp@redhat.com> |
| - automated rebuild |
| |
| * Mon Apr 29 2002 Jakub Jelinek <jakub@redhat.com> 1.4.2-4 |
| - fix makefile style variable passing ( |
| |
| * Thu Feb 28 2002 Jakub Jelinek <jakub@redhat.com> 1.4.2-3 |
| - rebuild |
| |
| * Wed Jan 09 2002 Tim Powers <timp@redhat.com> |
| - automated rebuild |
| |
| * Wed Nov 28 2001 Jakub Jelinek <jakub@redhat.com> 1.4.2-1 |
| - update to 1.4.2, mainly so that it can be built with gcc3+ |
| |
| * Fri Sep 7 2001 Jakub Jelinek <jakub@redhat.com> 1.4.1-3 |
| - make it noarch again |
| |
| * Wed Aug 29 2001 Jakub Jelinek <jakub@redhat.com> |
| - fix a typo ( |
| |
| * Thu Jun 28 2001 Tim Powers <timp@redhat.com> |
| - rebuilt for the distro |
| |
| * Tue Feb 27 2001 Tim Powers <timp@redhat.com> |
| - minor modifications to the spec file. Built for Powertools. |
| - added Epoch |
| |
| * Wed Feb 21 2001 Rob Savoye <rob@welcomehome.org> |
| - Fixed Requires line, and changed the URL to the new ftp site. |
| |
| * Sun Oct 31 1999 Rob Savoye <rob@welcomehome.org> |
| - updated to the latest snapshot |
| - added doc files |
| - added the site.exp config file |
| |
| * Mon Jul 12 1999 Tim Powers <timp@redhat.com> |
| - updated to 19990628 |
| - updated patches as needed |
| - added %%defattr in files section |
| |
| * Wed Mar 10 1999 Jeff Johnson <jbj@redhat.com> |
| - add alpha expect patch ( |
| - use %%configure |
| |
| * Thu Dec 17 1998 Jeff Johnson <jbj@redhat.com> |
| - Update to 19981215. |
| |
| * Thu Nov 12 1998 Jeff Johnson <jbj@redhat.com> |
| - Update to 1998-10-29. |
| |
| * Wed Jul 8 1998 Jeff Johnson <jbj@redhat.com> |
| - Update to 1998-05-28. |
| |
| * Sun Feb 1 1998 Jeff Johnson <jbj@jbj.org> |
| - Create. |
| |