%global apiver 1.6
# first two digits of version
%global release_version %(echo %{version} | awk -F. '{print $1"."$2}')
Name: atkmm
Version: 2.22.2
Release: 3%{?dist}
Summary: C++ interface for the ATK library
Group: System Environment/Libraries
License: LGPLv2+
URL: http://www.gtkmm.org/
Source0: http://ftp.gnome.org/pub/GNOME/sources/atkmm/%{release_version}/atkmm-%{version}.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: atk-devel
BuildRequires: glibmm24-devel
# atkmm was split out into a separate package in gtkmm24 2.21.1
Conflicts: gtkmm24 < 2.21.1
%description
atkmm provides a C++ interface for the ATK library. Highlights
include typesafe callbacks, widgets extensible via inheritance and a
comprehensive set of widget classes that can be freely combined to
quickly create complex user interfaces.
%package devel
Summary: Development files for %{name}
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: atk-devel
Requires: glibmm24-devel
Conflicts: gtkmm24-devel < 2.21.1
%description devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%package doc
Summary: Developer's documentation for the atkmm library
Group: Documentation
BuildArch: noarch
Requires: libsigc++20-doc
Requires: glibmm24-doc
%description doc
This package contains developer's documentation for the atkmm
library. Pangomm is the C++ API for the ATK accessibility toolkit library.
The documentation can be viewed either through the devhelp
documentation browser or through a web browser.
%prep
%setup -q
%build
%configure --disable-static
make %{?_smp_mfla gs}
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
%clean
rm -rf $RPM_BUILD_ROOT
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root,-)
%doc AUTHORS ChangeLog COPYING NEWS README
%{_libdir}/*.so.*
%files devel
%defattr(-,root,root,-)
%{_includedir}/atkmm-%{apiver}/
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%{_libdir}/atkmm-%{apiver}/
%files doc
%defattr(-, root, root, -)
%doc %{_docdir}/%{name}-%{apiver}/*
%{_datadir}/devhelp/
%changelog
* Mon Feb 21 2011 Haïkel Guémar <hguemar@fedoraproject.org> - 2.22.2-3
- split doc into subpackage
- fix documentation location
- co-own /usr/share/devhelp
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Thu Jan 13 2011 Kalev Lember <kalev@smartlink.ee> - 2.22.2-1
- Update to 2.22.2
* Tue Sep 28 2010 Kalev Lember <kalev@smartlink.ee> - 2.22.0-1
- Update to 2.22.0
* Tue Sep 14 2010 Kalev Lember <kalev@smartlink.ee> - 2.21.2-2
- Co-own /usr/share/gtk-doc/ directory (#604169)
* Wed Jun 30 2010 Kalev Lember <kalev@smartlink.ee> - 2.21.2-1
- Update to 2.21.2
* Sat Jun 26 2010 Kalev Lember <kalev@smartlink.ee> - 2.21.1-2
- added missing Conflicts: gtkmm24-devel to -devel subpackage
- calculate two-digit download directory from three-digit package version
* Wed Jun 23 2010 Kalev Lember <kalev@smartlink.ee> - 2.21.1-1
- Initial RPM release