%global apiver 1.6
# first two digits of version
%global release_version %(echo %{version} | awk -F. '{print $1"."$2}')
Name: atkmm
Version: 2.21.2
Release: 1%{?dist}
Summary: C++ interface for the ATK library
Group: System Environment/Libraries
License: LGPLv2+
URL: http://www.gtkmm.org/
Source0: http://ftp.gnome.org/pub/GNOME/sources/atkmm/%{release_version}/atkmm-%{version}.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: atk-devel
BuildRequires: glibmm24-devel
# atkmm was split out into a separate package in gtkmm24 2.21.1
Conflicts: gtkmm24 < 2.21.1
%description
atkmm provides a C++ interface for the ATK library. Highlights
include typesafe callbacks, widgets extensible via inheritance and a
comprehensive set of widget classes that can be freely combined to
quickly create complex user interfaces.
%package devel
Summary: Development files for %{name}
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: atk-devel
Requires: glibmm24-devel
# for /usr/share/gtk-doc/html
Requires: gtk-doc
Conflicts: gtkmm24-devel < 2.21.1
%description devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%prep
%setup -q
%build
%configure --disable-static
make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
# Fix documentation installation, put everything under gtk-doc and fix
# relative paths.
mkdir -p $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/atkmm-%{apiver}
mv $RPM_BUILD_ROOT%{_docdir}/atkmm-%{apiver}/* $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/atkmm-%{apiver}/
mv $RPM_BUILD_ROOT%{_datadir}/devhelp/books/atkmm-%{apiver}/*.devhelp2 $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/atkmm-%{apiver}
# Fix broken devhelp base tag
sed -i 's:base="[^\"]*":base="/usr/share/gtk-doc/html/atkmm-%{apiver}/reference/html":' $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/atkmm-%{apiver}/*.devhelp2
%clean
rm -rf $RPM_BUILD_ROOT
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root,-)
%doc AUTHORS ChangeLog COPYING NEWS README
%{_libdir}/*.so.*
%files devel
%defattr(-,root,root,-)
%{_includedir}/atkmm-%{apiver}/
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%{_libdir}/atkmm-%{apiver}/
%{_datadir}/gtk-doc/html/atkmm-%{apiver}/
%changelog
* Wed Jun 30 2010 Kalev Lember <kalev@smartlink.ee> - 2.21.2-1
- Update to 2.21.2
* Sat Jun 26 2010 Kalev Lember <kalev@smartlink.ee> - 2.21.1-2
- added missing Conflicts: gtkmm24-devel to -devel subpackage
- calculate two-digit download directory from three-digit package version
* Wed Jun 23 2010 Kalev Lember <kalev@smartlink.ee> - 2.21.1-1
- Initial RPM release