42b017 Add upstream patch to explicitly include sys/types.h

Authored and Committed by Stephen Gallagher 11 years ago
    Add upstream patch to explicitly include sys/types.h
    
        
alsa-lib-sys-types.patch ADDED
@@ -0,0 +1,35 @@
1
+ From 3e7dc283ed2d3ed2341f0657811c588f4dbcba6d Mon Sep 17 00:00:00 2001
2
+ From: David Henningsson <david.henningsson@canonical.com>
3
+ Date: Tue, 12 Feb 2013 10:06:11 +0100
4
+ Subject: [PATCH] Add sys/types.h to include list
5
+
6
+ This is needed by snd_pcm_format_silence* functions which
7
+ return u_int*_t. It was discovered while trying to compile ALSA
8
+ programs with eglibc 2.17.
9
+
10
+ Credits to Richard Shaw, Gary Buhrmaster, Matthieu Baerts and
11
+ Adam Conrad for this fix.
12
+
13
+ BugLink: https://bugs.launchpad.net/bugs/1109298
14
+ BugLink: https://bugzilla.redhat.com/show_bug.cgi?id=885306
15
+ Signed-off-by: David Henningsson <david.henningsson@canonical.com>
16
+ Signed-off-by: Takashi Iwai <tiwai@suse.de>
17
+ ---
18
+ include/asoundlib-head.h | 1 +
19
+ 1 file changed, 1 insertion(+)
20
+
21
+ diff --git a/include/asoundlib-head.h b/include/asoundlib-head.h
22
+ index 20c8a68..6edbab0 100644
23
+ --- a/include/asoundlib-head.h
24
+ +++ b/include/asoundlib-head.h
25
+ @@ -31,6 +31,7 @@
26
+ #include <unistd.h>
27
+ #include <stdio.h>
28
+ #include <stdlib.h>
29
+ +#include <sys/types.h>
30
+ #include <string.h>
31
+ #include <fcntl.h>
32
+ #include <assert.h>
33
+ --
34
+ 1.7.11.4
35
+
file modified
+6 -1
alsa-lib.spec CHANGED
@@ -5,7 +5,7 @@
5
5
Summary: The Advanced Linux Sound Architecture (ALSA) library
6
6
Name: alsa-lib
7
7
Version: 1.0.26
8
- Release: 3%{?prever_dot}%{?dist}
8
+ Release: 4%{?prever_dot}%{?dist}
9
9
License: LGPLv2+
10
10
Group: System Environment/Libraries
11
11
URL: http://www.alsa-project.org/
@@ -17,6 +17,7 @@ Source12: modprobe-dist-oss.conf
17
17
Patch0: alsa-lib-1.0.24-config.patch
18
18
Patch2: alsa-lib-1.0.14-glibc-open.patch
19
19
Patch4: alsa-lib-1.0.16-no-dox-date.patch
20
+ Patch5: alsa-lib-sys-types.patch
20
21
21
22
BuildRequires: doxygen
22
23
Requires(post): /sbin/ldconfig, coreutils
@@ -47,6 +48,7 @@ against the ALSA libraries and interfaces.
47
48
%patch0 -p1 -b .config
48
49
%patch2 -p1 -b .glibc-open
49
50
%patch4 -p1 -b .no-dox-date
51
+ %patch5 -p1 -b .sys-types
50
52
51
53
%build
52
54
%configure --disable-aload --with-plugindir=%{_libdir}/alsa-lib --disable-alisp
@@ -107,6 +109,9 @@ find %{buildroot} -name '*.la' -exec rm -f {} ';'
107
109
%{_datadir}/aclocal/alsa.m4
108
110
109
111
%changelog
112
+ * Wed Apr 03 2013 Stephen Gallagher <sgallagh@redhat.com> - 1.0.26-4
113
+ - Add upstream patch to explicitly include sys/types.h
114
+
110
115
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.26-3
111
116
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
112
117